Blokir facebook dan youtube dengan L7 MikroTik

29 10 2011

Thanx to :

 

Bagi Anda admin perkantoran yang mengalami kesulitan untuk memblokir situs jejaring sosial ataupun situs-situs yang membuat aktifitas bekerja terganggu berikut cara sederhana jika jaringan kantor anda tidak memakai server proxy cukup memakai Router MikroTik.

Pertama buat script L7 seperti berikut

value regex bisa Anda tambahin sendiri sesuai kebutuhan tinggal menyisipkan diantara tanda (bla|test )
contoh facebook dan youtube

1 ^.+(facebook|youtube).*$

Kedua buat filter menggunakan L7

dst-address adalah alamat komputer klien, jika ingin memakai banyak klien cukup mebuat address-list seperti ini

pilih Layer 7 protokol “denied”

catatan:
jika menggunakan address-list maka dst-address pada tab general harap di kosongin.

pindah ke tab action pilih drop

buat comment “denied”

tekan OK selesai sekarang situs jejaring sosial tidak dapat di akses melalui komputer dengan alamat yg telah ditentukan tadi.

Sekarang membuat jadwal kapan situs jejaring sosial di tutup maupun dibuka hanya untuk waktu tertentu.
Buka menu script seperti pada gambar

buat script untuk perintah tutup/blockir

sourcenya:

1 /ip firewall filter set [/ip firewall filter find comment="denied"] disable="no"

buat script untuk perintah buka/bypass

sourcenya:

1 /ip firewall filter set [/ip firewall filter find comment="denied"] disable="yes"

Setelah script selesai dibuat sekarang membuat schedulenya

membuat jadwal tutup jam 8 pagi di setiap hari

jadi ini akan menutup situs yang di blokir setiap jam 8 pagi

membuat jadwal buka jam 12 siang

jadi ini akan membuka situs yang di blokir setiap jam 12 siang

Dan untuk selanjutnya silahkan di sesuikan dengan jam kantor masing-masing :)

TEsted!!! Its Work

dikutip dari :  http://reges007.wordpress.com/





Block IM Messenger in Mikrotik With Layer 7

29 10 2011

Blocking Yahoo Messenger
1. buka winbox dan klik “New Terminal. copas script dibawah ini

/ip firewall layer7-protocol add comment="Blocking Yahoo Messenger" name=Yahoo Messenger regexp="^(ymsg|ypns|yhoo).\?.\?.\?.\?.\?.\?.\?[lwt].*\\xc0\\x80\?"
/ip firewall filter add action=drop chain=forward comment="Block YM" disabled=no layer7-protocol=Yahoo Messenger src-address=ip.tersangka.yang.suka.chating

Blocking MSN Messenger
1. buka winbox dan klik “New Terminal. copas script dibawah ini juga😀

/ip firewall layer7-protocol add comment="Blocking MSN Messenger" name=MSN Messenger regexp="ver [0-9]+ msnp[1-9][0-9]? [\x09-\x0d -~]*cvr0\x0d\x0a$|usr 1 [!-~]+ [0-9. ]+\x0d\x0a$|ans 1 [!-~]+ [0-9. ]+\x0d\x0a$"
/ip firewall filter add action=drop chain=forward comment="Block MSN" disabled=no layer7-protocol=MSN Messenger src-address=ip.tersangka.yang.suka.chating

Tested!!!It’s Work

diambil dari : Fajar Nugroho & “http://komunitaskita.net”

 





How to Change or Remove “Designed by JoomlArt.com” in Joomla 1.5 Template

12 04 2011

From  http://adedarmawan.blogspot.com

At the bottom or footer on each joomla template that we use (in this case JA DROID template) have the sentence/phrase “Designed by JoomlArt.com”. Because of one or more of the reasons we want to change or remove the phrase (do not change the original designer name with our name, it violates the Intellectual Property Rights).
For “Copyright” and “Joomla! is Free Software…” sentence, we can edit, change or remove it like we did on default template that distributed with Joomla packet. You can edit “en-GB.mod_footer.ini” file in this folder:
joomla_root_folder\language\en-GB.
But we can’t change, edit or remove “Designed by Joomlart.com”
There’s no “template\ja_ (name_of_the_template)\HTML\mod_footer\default.php” anymore.
In the Joomlart new template, in this case JA DROID, that “default.php” is moved to somewhere else folder.
It’s painful searching… but at last I can find it and want to share it with you, but remember that this is Just Sharing All The Things I Know…
Well, enough with bla bla bla thing🙂 , now try to open “default.php” file in this folder:
joomla_root_folder\plugins\system\jat3\base-themes\default\html\mod_footer\default.php
Now it’s up to you to….

tested…Its Work….





install Smokeping di Windows

23 09 2010

Ngikutin Tutorial dari

http://dev.pulsed.net/wp/?p=3


is the new way to go for Smokeping under Windows

1) smokewhat?

Smokeping(link) is a nice latency measurement tool, unfortunately it WAS only available for linux/unix…but after the jump, you’ll find how to make it work under Microsoft Windows!

SmokePing is a deluxe latency measurement tool. It can measure, store and display latency, latency distribution and packet loss. SmokePing uses RRDtool to maintain a longterm data-store and to draw pretty graphs, giving up to the minute information on the state of each network connection.

2) What you need

Perl (choose Perl 5.8.xxx MSI package for Windows)
Yeah Perl is cool and you can have a lot of fun using it

RRDs module for Perl
This version works for sure, but feel free to download the latest

fping for windows (thanks to Michael Parson)

Smokeping
This version works for sure, but feel free to download the latest

– a text editor
There’s a lot of text editors out there… personally, I like pspad

– a web server
Feel free to download, install, configure apache with cgi yourself, or use WAMP (the one I use), or whatever bundled apache/cgi/php/mysql version you want

3) What you do not need

– Money
all listed softwares are (at least) freeware

– A (linux/unix)-running computer
yeah dude, windows rulez da w0rld

4) “Installation”

– Install Activestate Perl
– Install RRDtool for windows (unzip, and launch install.cmd)
– Unzip smokeping to C:\smokeping-2.0.8
– Unzip fping for windows (make sure cygwin1.dll is in the same folder) to C:\smokeping-2.0.8\fping
– Install WAMP to C:\wamp

5) Modifications

a) rename
C:\smokeping-2.0.8\bin\smokeping.dist into smokeping.pl
C:\smokeping-2.0.8\bin\tSmoke.dist into tSmoke.pl

b) edit
C:\smokeping- 2.0.8\bin\smokeping.pl
add (after line 5): use lib qw(C:\smokeping-2.0.8\lib);
change (line 9): Smokeping::main(“etc/config.dist”); into Smokeping::main(“C:/smokeping-2.0.8/etc/config.dist”);

C:\smokeping-2.0.8\bin\tSmoke.pl
change (line 63): my $cfgfile = “etc/config.dist”; into my $cfgfile = “C:\smokeping-2.0.8\etc\config.dist”;

C:\smokeping- 2.0.8\lib\Smokeping.pm
change (line 14): use Sys::Syslog qw(:DEFAULT setlogsock); into #use Sys::Syslog qw(:DEFAULT setlogsock);
change (line 21): $ENV{LC_NUMERIC}=’C’; into #$ENV{LC_NUMERIC}=’C’;
change (line 22): POSIX::setlocale(&POSIX::LC_NUMERIC,””); into #POSIX::setlocale(&POSIX::LC_NUMERIC,””);
change (line 2984): daemonize_me $cfg->{General}{piddir}.”/smokeping.pid”; into #daemonize_me $cfg->{General}{piddir}.”/smokeping.pid”;

C:\wamp\Apache2\conf\httpd.conf
change (line 515): ScriptAlias /cgi-bin/ “C:/wamp/Apache2/cgi-bin/” into ScriptAlias /cgi-bin/ “c:/wamp/cgi/”
change (line 521): <Directory “C:/wamp/Apache2/cgi-bin/”> into <Directory “c:/wamp/cgi”>

c) move and rename
– Create folder c:\wamp\cgi
C:\smokeping-2.0.8\htdocs\smokeping.cgi.dist to c:\wamp\cgi\smokeping.pl

d) edit
c:\wamp\cgi\smokeping.pl
change (line 1): #!/usr/sepp/bin/speedy -w into #!C:/Perl/bin/perl.exe -w
change (line 5): use lib qw(/home/oetiker/data/projects/AADJ-smokeping/dist/lib); into use lib qw(C:\smokeping-2.0.8\lib);
change (line 10): Smokeping::cgi(“/home/oetiker/data/projects/AADJ-smokeping/dist/etc/config”); into Smokeping::cgi(“C:/smokeping-2.0.8/etc/config.dist”);

6) Configuration

– Create folders:
C:\wamp\www\simg
C:\smokeping- 2.0.8\var

– edit configuration file ( C:\smokeping- 2.0.8\etc\config.dist ) no line number here use search function instead :p

owner =
contact =
mailhost =
#sendmail = /usr/lib/sendmail < == Comment this line
imgcache = C:/wamp/www/simg
imgurl = ../simg
datadir = \smokeping-2.0.8/var # designate implicitly c:\smokeping-2.0.8\var
piddir = C:/smokeping-2.0.8/var
cgiurl = http://127.0.0.1/cgi-bin/smokeping.pl
smokemail = C:/smokeping-2.0.8/etc/smokemail.dist
tmail = C:/smokeping-2.0.8/etc/tmail.dist

# syslogfacility = local0 < = Comment this line!!!!

*** Alerts ***
to =
from =

template = C:/smokeping-2.0.8/etc/basepage.html.dist

+ FPing
binary = C:/smokeping-2.0.8/fping/fping.exe

title =
remark =

# google is for demonstrational purpose only; please refer to smokeping help to set your own targets

+ Google

menu = Google
title =Google Connectivity
alerts = bigloss,someloss,startloss
host = google.fr

7) Test it!

– open a cmd.exe window, and type C:\smokeping-2.0.8\bin\smokeping.pl

Ok, no weird error messages (if not, please check 5-a, 5-b and 6 again)

– let it run for 10-15 min and try to open http://127.0.0.1/cgi-bin/smokeping.pl

Ok, no error messages again (if not: for cgi error check 5-b, 5-c, 5-d and 6 again and 5-d and 6 for RRD errors)
(note the 2 buggy images bottom left, we will fix this later)

Now close the cmd.exe windows (a little bit rebel)

Tested! Its Work

Source form :

http://dev.pulsed.net/wp/?p=3





Mikrotik : Memisahkan Bandwidth International dengan IIX

14 07 2010

Kasus

Anda mempunyai warnet games online, di warnet anda mempunyai aktifitas pelanggannya adalah browsing dan games online. Jika pelanggan anda ada yang browsing atau download, pelanggan yang bermain games online terganggu (LAG). Mungkin anda punya rencana memakai 2 ISP dengan tujuan 2 aktifitas itu dibagi koneksinya, 1 untuk browsing 1 lagi untuk games online.

Kondisi Jaringan

ISP pertama mempunyai IP 10.10.10.2/30 gateway 10.10.10.1 pada ether1 (untuk koneksi IIX)
ISP kedua mempunyai IP 20.20.20.2/30 gateway 20.20.20.1 pada ether2 (untuk koneksi internasional)
Jaringan lokal mempunyai IP 192.168.0.0/24 pada ether3

Quick Start

Sebelumnya anda harus mempelajari tutorial Memisahkan Bandwidth Internasional dan IIX karena saya kembangkan dari tutorial tersebut.

Saya anggap anda sudah membuat paket mark internasional dan IIX dalam ip firewall mangle.

/ip address
add address=10.10.10.2/30 interface=ether1 comment=ISP 1 for IIX disabled=no
add address=20.20.20.2/30 interface=ether2 comment=ISP 2 for Internasional disabled=no
add address=192.168.0.1/24 interface=ether3 disabled=no

/ip firewall mangle
add chain=prerouting src-address=192.168.0.0/24 dst-address=nice action=mark-routing new-routing-mark=iix disabled=no comment=Routing Mark for IIX

/ip route
add gateway=20.20.20.1
add gateway=10.10.10.1 routing-mark=iix

/ip firewall nat
add chain=srcnat action=masquerade disabled=no

Explanation

Sekarang saya coba jelaskan satu-satu rules diatas



/ip firewall mangle
add chain=prerouting src-address=192.168.0.0/24 dst-address-list=nice action=mark-routing new-routing-mark=iix disabled=no comment=Routing Mark for IIX

Rules diatas adalah membuat mark routing dengan nama “iix” untuk koneksi iix, bagaimana tau itu buat iix? saya menggunakan dst-address-list=nice (paket dari client yang menuju ip yang terdaftar pada address-list “nice”), bagaimana nice itu bisa ada? pelajari tutorial Memisahkan Bandwidth Internasional dan IIX disitu ada caranya.

/ip route
add gateway=20.20.20.1
add gateway=10.10.10.1 routing-mark=iix

Kita menggunakan primary gateway 20.20.20.1 yang difungsikan untuk koneksi internasional. Untuk koneksi IIX menggunakan 10.10.10.1 dengan routing-mark=iix yang sudah kita buat di ip firewall mangle. Loh kok internasional ga dibuat routing mark juga? karena kita hanya perlu mark routing untuk iix saja, jika ada paket yang tidak diproses oleh routing-mark “iix” maka otomatis melewati primary gateway dan itu bisa dibilang koneksi internasional Karena untuk paket IIX diproses oleh mangle dan rules routing kedua (routing-mark “iix”)

/ip firewall nat
add chain=srcnat action=masquerade disabled=no

Untuk NAT kita buat “masquerade” agar proses Network Address Translation (nat) bekerja otomatis pada kedua gateway tersebut.

Taken from http://adamonline.web.id/





Panduan Mencari atau Menilai Asisten manager, Coach, Scout dan Physio

7 01 2009

FM 2009 Staff GuideIni adalah panduan cara melihat atribut penting tiap jenis staff dari Asisten, Coach, Scout dan Physio. Hal apa saja yang harus dilihat dalam menilai seorang staff agar kinerja tim anda bisa optimal.

Coach

  • First Team Coach (hanya melatih tim utama)
  • Coach (melatih tim utama dan junior)
  • Youth Coach (hanya melatih tim junior)
  • Fitness Coach (pelatih fisik)
  • Goalkeeper Coach (pelatih kiper)
Atribut Penting Mental:

Adaptability – Ini penting jika anda memakai pelatih luar negeri, diluar negara tempat liga klub anda.
Motivating – Pemain akan lebih semangat dalam latihan jika atribut ini tinggi.
Level of Discipline – Mendisiplinkan pemain, membuat mereka lebih fokus latihan.
Working with Youngsters – Ini atribut sangat penting bagi Youth Coach, penting juga jika tim utama anda banyak pemain mudanya.
Man Handling – Menangani karakter tiap pemain dengan baik

Atribut Penting Teknis:

Misalnya seorang pelatih mempunyai kemampuan technique=18, mental 17, attacking 19 – maka ia dapat melatih set pieces dengan baik sekali (7 bintang). Untuk lainnya bisa dilihat di tabel berikut:

Penempatan Coach (Pelatih) Dalam Training
Goalkeeping GK >= 18
Strength Fitness >= 18
Aerobic Fitness >= 18
Tactics Tactical >= 18
Defending Defending = 18 & Tactical>= 18 atau

Defending = 19 & Tactical>= 14 atau

Defending = 20 & Tactical>= 10

Ball Control Technique = 18 & Mental>= 18 atau

Technique = 19 & Mental>= 14 atau

Technique = 20 & Mental>= 10

Attacking Attacking = 18 & Tactical >= 18 atau

Attacking = 19 & Tactical >= 14 atau

Attacking = 20 & Tactical >= 10

Shooting Attacking = 18 & Technical>= 18 atau

Attacking = 19 & Technical>= 14 atau

Attacking = 20 & Technical>= 10

Set Pieces Technique = 17 & Mental + Attacking >= 39 atau

Technique = 18 & Mental + Attacking >= 36 atau

Technique = 19 & Mental + Attacking >= 33 atau

Technique = 20 & Mental + Attacking >= 30

Assistant Manager

Asisten Manager tidak harus mempunyai skill seperti seorang coach seperti diatas, namun jika ia mempunyai skill yang baik sekali sebagai coach, maka ini benar-benar anugerah karena ia bisa ikut membantu training tim anda.

Atribut Utama

Judging Player Ability – Ini penting jika anda memintanya laporan tim atau laporan per-pemain.
Tactical Knowledge – Penting jika anda menugaskannya menangani tim reserve.
Working with Youngsters – Penting jika anda menugaskannya menangani tim junior (U18).
Man Handling – Ia akan memberikan masukan yang baik jika ada pemain yang bermasalah.
Motivating + Level Discipline – memberi masukan yang baik saat team talk (jeda turun minum pertandingan).

Atribut Pendukung

Keahlian sebagai Coach (baca di atas).

Scout

Atribut Utama

Judging Player Ability – Kemampuan melihat skill pemain saat sekarang
Judging Potential Ability – Kemampuan melihat potensi skill pemain, kemampuan pemain pada nantinya (ini penting jika anda suka menggunakan pemain muda).

Atribut Pendukung

Adaptability – Jika anda mengirimkan seorang scout dengan adaptasi tinggi ke negara lain, maka scout tersebut akan lebih cepat menjelajahi negara tersebut.
Determination – Keinginan keras untuk menemukan lebih banyak pemain.
Tactical Knowledge – Ini penting jika anda menugaskan seorang scout untuk ‘Scouting Next Opposition’ (Mengintip calon lawan), laporan scout yang mempunyai tactical knowledge tinggi akan lebih lengkap.

Physios

Atribut Utama

Physiotherapy – Ini adalah yang paling penting, jika tidak, seorang physio tidak ada gunanya.

Atribut Pendukung

Level of Discipline – Mengawasi pemain yang cedera agar tidak semakin memburuk kondisi fisiknya akibat ketidak disiplinan sang pemain.
Motivating – Memotivasi pemain yang cedera agar mempercepat kesembuhan.
Man Handling – Physio yang bisa menangani karakter tiap pemain dengan baik, bisa mempercepat kesembuhan.





5 Faktor Penting Selain Taktik Dalam FM 2009

7 01 2009

Football Manager tidaklah melulu soal taktik pertandingan, ada faktor-faktor lain yang menentukan kesuksesan tim anda. Seperti dalam dunia sepakbola sesungguhnya, taktik yang hebat sekalipun tidak akan berguna jika tim anda belum menyatu dengan baik atau manajemen yang buruk misalnya bukan ?

5 Faktor Penting Selain Taktik FM 2009
Reputasi Manager Tim selalu membutuhkan waktu untuk dapat mulai mengerti dan juga menghormati segala keputusan yang dibuat seorang manager, apalagi  manager baru yang mempunyai reputasi minim tetapi berada di klub multi bintang.
Kesatuan Tim Tim yang belum menyatu dengan baik (squad gelling) maka akan sulit bermain dengan baik, tidak peduli seberapa bagusnya taktik anda. Tim yang baru saja mentransfer begitu banyak pemain kelas dunia pun, pasti akan kesulitan bermain baik pada awalnya.

Untuk mengakalinya, bermainlah lebih konservatif (jangan terlalu ambisius dengan taktik menyerang yang disertai creative freedom tinggi pada beberapa pertandingan awal, sebaliknya bermainlah agak defensive plus creative freedom rendah) sampai tim anda sudah mulai menyatu dengan baik.

Manajemen Pemain & Media Pemain akan tidak senang (unhappy) jika kemampuan manajerial kita buruk. Pemain yang sedang unhappy biasanya juga bermain tidak konsisten, dan kalau sudah begitu tentunya akan mempengaruhi performa tim yang berujung pada kekalahan.

Karenanya, belajarlah bagaimana menangani tiap-tiap karakter pemain (tepat saat memuji atau mengkritiknya) dan menghadapi media (press) dengan baik.

Strategi Transfer & Finansial Taktik yang hebat tetapi tanpa didukung oleh pemain yang mumpuni maka akan sia sia. Oleh karena itu strategi transfer pemain yang baik penting sekali disini. Fokuslah hanya pada pemain yang cocok bagi tim anda, baik secara skill maupun permintaaan gajinya. Kontrol juga struktur gaji klub anda, agar tidak membuat klub menjadi bangkrut nantinya.
Progranm Training Program latihan (training) yang baik akan merangsang pemain agar mereka bisa mengeluarkan seluruh kemampuan terbaiknya. Dan bagi pemain muda, ini akan mendorong pencapaian potensi penuhnya.
Program training yang baik juga sangat membantu agar visi taktik seorang manager bisa dituangkan dalam permainan sesungguhnhya.